jQuery1.9及以上版本检测IE版本号

jQuery 从 1.9 版开始,移除了 $.browser 和 $.browser.version , 取而代之的是 $.support 。 在更新的 2.0 版本中,将不再支持 IE 6/7/8。 以后,如果用户需要支持 IE 6/7/8,只能使用 jQuery 1.9。

如果要全面支持 IE,并混合使用 jQuery 1.9 和 2.0, 官方的解决方案是:

 

除此之外,我们还可以使用纯js来进行判断浏览器版本,不需要额外调用低版本jQuery,而且不会和jquery高版本冲突。完美兼容IE6,整理后的代码如下:

 

另外,附上jQuery源调用接口链接:

http://www.bootcdn.cn/jquery/

-全文完-

原文链接:,转发请注明来源!

发表评论